20170821 Linux & digital modes

I’m not very good at writing in depth reports or things like that, this blog / site is purely like a diary for me and hopefully you enjoy reading it – so please don’t expect to read below and find the answers to your digital / Linux problems… its not that kind of post… its just some passing thoughts and more so, a message of thanks to those that imparted their wisdom and got me up and running, its about my new Icom IC-7300, a new operating system (Linux Mint) and the connection of the radio to the computer… it wont be technical as my brain hasn’t retained much about how I did it but it will be a bit about the problems I faced.

Note to Icom – supply the IC-7300 with a USB cable please! The printer type USB cable needed to connect the radio to the computer isn’t in the box and only because Peter @2m0sql (thanks Pete) told me beforehand ‘sort one so as not to be disappointed’ was I not – I had to have a good hunt around but luckily I had one at work in a ‘junk’ box, as you would expect 😉

Now I had the cable it was time to connect the computer – for whatever reason my Windoze 7 install was corrupt (had been for almost a year) and I was unable to install any USB drivers so it wouldn’t read / write to a USB stick or anything, I couldn’t even install a Microsoft web-cam.

Reading up on the internet Windows needed a clean install… after I had the problems the first time finding drivers for the motherboard I wasn’t going to do that…  So my plan was to dual boot and install Linux because I wasn’t ready for a cold turkey approach to the MS withdrawal – however the Windows install was that bad the Linux distro (Mint 17.1 – why 17.1? just because it was a CD that was lying around, no other reason) didn’t recognise there was another operating system and wouldn’t install as a dual boot – because I wasn’t ready to format the drive I found another one and did a clean install on a separate 150GB HDD – other than dipping back for LoTW stuff I haven’t been back to Win7 which hopefully is a good sign…

So here goes nothing – the learning curve was extremely acute, not only a change in operating system but all the software that goes with it.. luckily being only 18 months in to my ham radio journey I hadn’t been too brainwashed in to certain software so learning anything new when it came to digital was going to be another struggle anyway. If I was going to do something new then it wouldn’t matter what OS I was using…

Oh hell… little bits and bobs I had problems with, its not like windows where you just download an .exe file and install it… its much more convoluted – that being said, that’s probably just me being new to Linux… when I understand the process it will probably be easier, I hope it is anyway…

Then the struggle I had with LoTW certificates – I didn’t realise you can back up your ‘working’ version of “TrustedQSL” (TQSL) and then use that to move to another computer – I would STRONGLY recommend you set up a Dropbox account or similar and backup your logs and TQSL directly to it so you don’t ever run the risk of losing stuff or requesting new certificates from the ARRL… in fact all my radio stuff is on a Dropbox account for that very reason… my computer may crash but I wont loose my data 🙂

I need to thank a load of people (tweeps) at this point as this post, as above, is really to thank them, without their help & comments etc I’d have probably fallen back to Windows.. If I have missed anyone I’m really sorry, but it doesn’t negate your input… its been really good of everyone to point me in the right direction and also to spend their time explaining things and answering my dumbarse questions.

Thank you!!

Dave – MW0DCM – @dave_maydew
David – M0TDN – @M0TDN
Simon – G0FCU – @g0fcu
Dave – M6RUG – @ThorpeDave
Dave – MM3ZRZ – @hibbie
John – DK9JC – @DK9JC
Paul – N8HM @PRStoetzer

(4 x Daves – that’s scary!!)

Moving forward… the IC-7300 is now connected to the computer that’s running Linux.

Now that I’ve been helped this far to get the set up right what’s next……..?

I know lets install WSJT-X and try this new FT8 everyone has been talking / raving about – strangely I find myself hooked – I never thought I would say that – spare ‘radio time’ is now spent on FT8 at the same time as surfing the web (in fact part of this post was written whilst making FT8 QSO’s), it’s one of those modes you can almost leave and let it work the DX itself (but not quite) – it does require a little human intervention but not much… I’ve found the propagation of FT8 not dissimilar to SSB on a good day (at current solar conditions) and FT8 is also right up the street of those 59/QRZ types – its not conversational at all and I’m even quite enjoying that quick exchange.

 

I have particularly enjoyed the propagation reports from PSK Reporter when using FT8 – a very clever tool and in good ham tradition its a hobby project and completely free – the PSK Reporter maps are amazing!! Take a look if you are thinking of playing digital modes or are new to them, its well worth it! You can see who is hearing who or where you are being heard. You can call CQ and almost immediately get reports coming back through the system.

I’ve briefly tried JT65 – that is painfully slow… I don’t get that… far too long winded… I’ve also tried to get FLDigi to work but some settings are slightly different on the radio I think, I seemed to get it to work but didn’t manage any QSO’s and then visited it again a week or so later and couldn’t receive / decode anything.

Next stop SSTV (if I can get myself off FT8) 😉

UPDATE: 12th June 2018
Bob, KD2BOB asks some questions below in the comments about setting up Mint and WSJT-X… hopefully the images and link below helps…

 

 

and then below you need to set up your IC-7300… follow the link for the basic settings…. you will have to tweak them – one important point…

https://wa7ewc.wordpress.com/2016/04/27/icom-ic-7300-digital-mode-settings/

GOOD LUCK! – please let me know how you get on!

15 Comments

  1. You will enjoy SSTV if you try it. Just download MSSTV and use the standard supplied until you upload your own pictures.

    • Thanks Nigel – I’m a bit of a tog and enjoy the craft 🙂 so will most definitely do some of my own – I will be trying both MMSTV and QSSTV – I like to fiddle, I’m just not very good at it 🙂

      • oooh, on looking though MSSTV is a windows only software so looks like its QSSTV or bust 🙂

  2. I’ve got an IC-7300 and the WSJT-X loaded on my Linux Mint 18.2 OS. Got the USB cable hooked up to the PC and 7300. But instructions for the 7300 mentioned you need a USB driver for this to work. I didn’t see any reference in your blog, so how did you do this? Is there a Linux USB driver for the 7300?

    Cheers,
    Bob /KD2BOB

    • Good morning Bob

      Sorry for delayed response… i think you will find that the instructions for drivers would be for Windows operating systems – i didn’t have to do much to get it working – any digi mode – its the sound card selection that confused me – ie you are using the card in the 7300 and not the one in the computer.

      Given my delayed response have you now managed to get it running?

      73 – Adam

      • Hello, Adam

        I’m at the point of forgetting Linux OS and installing Win 8.1 so I can take advantage of both the USB driver and using WSJT-X (not supported by Linux). I had an email from the ic-7300 user group yesterday with the link to Icom in Japan for the latest USB driver. Now all I have to do is get 8.1 installed without trashing my hard drive. LOL

        Thanks for the reply.

        73 -Bob

        • Hiya

          WSJT-X does work with Linux, very well – it’s what i use with Mint too – you don’t need the windows driver as this is just for the USB and Mint does it without too much pain, unlike Windows – it just works assuming you make the radio connection to the computer and you have the sound card set correctly…. when i get home after work i’ll try and give you some screen shots.

          However in the meantime below is the link to WSJT-X for linux…

          https://physics.princeton.edu/pulsar/k1jt/wsjtx.html

          Scroll to “Linux” and choose your distro – for Mint its the Ubuntu choice and depending on your computer will depend on if you need the 32 bit or the 64 bit…

          Good luck! 🙂

  3. I very much look forward to your screen shots. I’ve downloaded WSJT-X onto my Linux Mint and will wait to see your setup connections. I have the Type A – Type B USB cable connected from the 7300 to my HP PC. Thanks.

    Bob

    • Hi Bob

      here is a link to a dropbox… i wont leave it there but i will add to my original post shortly

      https://www.dropbox.com/sh/1xfximohzh50bn3/AAB2aPjDUA6cR1qHKF-kJzQka?dl=0

      Note, your sound cards may be different and you may need to select them in Linux (the 7300 ones) when setting up Mint too…

      Also, below is a link to a web page about how to set your 7300 audio – disregard the windows comments and scroll down to “Set UP your IC-7300 for Digital Modes”

      Icom IC-7300 Digital Mode Settings

      Let me know how you get on eh!

      • Adam,

        I just created a Dropbox and have two screenshots to show you. But, still learning how to share. I tried copying the address above to share but it said invalid. Don’t want to waste too much of your time on this. In a nutshell, after entering the items in your second link above, the error said something to this effect: hamlib error: IO while opening rig

        73 / Bob

        • Hiya – if i can help you get set up then its not a waste of time… so many helped me and i truly appreciate it – its hard when you get lost amongst an operating system you are not familiar with… seriously no problem… what’s also good is that others will hopefully see this conversation and it will help them too 🙂

          I’m guessing you cant select the IC-7300 on the menu on the “Radio” tab?

          Try this link…. follow the instructions 🙂

          fldigi with Icom IC-7300

          AGAIN, good luck…!! and you are NOT wasting my time!!! 🙂

          • Hi Adam,

            Re the settings, I’ve copied yours exactly on each tab, the exception being the audio (due to my particular pc sound card?). Also entered the exact settings on the 7300 per the link. The 7300 is connected to the PC via a USB cable. The issue seems to be centered on the I/O settings or hardware. The FLDIGI article you referenced in your reply looks like the solution as it mentions the 7300 does NOT use the HAMLIB to connect. And that is the error message I get.

            So, I’ll follow the FLDIGI settings and see what happens.

            Cheers,

            Bob

          • sorry – i’m a bit hit and miss… not good at this stuff and muddle my way through… HAMLIB seemed to be what was needed to be able to select the rig on the “Radio” tab if i remember correctly…. sorry for not being much use… 🙁

    • it wasnt hard honestly… i’m not very good with Linux so if i can do it then anyone can…

      FYI i have now added to the page too 🙂

      Please let me know eh!! 🙂

      73 – Adam 🙂

Leave a Reply to Nigel Cancel reply